Email Issues
Incident Report for
BrightManager
Resolved
This incident has been resolved.
Posted
Sep
01
,
2025
-
16:51
BST
Identified
We are aware of issues affecting the processing of incoming emails in BrightManager. The root cause has been identified, and our teams are actively working on a fix.
Posted
Sep
01
,
2025
-
10:33
BST
This incident affected: Email & SMS.
×
Subscribe to Incident
Subscribe to updates for
Email Issues
via . You'll receive .